Java SE 6 fix for Illustrator CS5

I recently updated my Mac to High Sierra and Illustrator CS5bwould no longer launch, because it wanted Java SE 6. I downloaded and installed Apple’s Java SE 6 run time, because the other workaround that follows DID NOT work, even though I tried enabling the root user and booting into Single User Mode to try and execute the following:

sudo mkdir -p /System/Library/Java/JavaVirtualMachines/1.6.0.jdk

sudo mkdir -p /System/Library/Java/Support/Deploy.bundle

ln -s /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents

Leave a Reply